x

Uso de cookies

Utilizamos cookies propias y de terceros para mejorar nuestros servicios y mostrarle publicidad relacionada con sus preferencias mediante el análisis de sus hábitos de navegación.
Si continúa navegando, consideramos que acepta su uso. Puede obtener más información, o bien conocer cómo cambiar la configuración, en nuestra Política de cookies

 
  Entrar Regístrate
 
Problema con CSS
#1 · 24/Sep/2008, 13:13

Buenos dias a todos.
Estoy haciendo varias aplicaciones web, las cuales usan los mismos estilos. Lo que he hecho ha sido crear en la carpeta raíz las subcarpetas de cada aplicación, y tambien añadí a la raíz el estilos.css, para hacerle referencia desde los distintos archivos.
:-]

La cosa es que al listar una tabla, tengo unas imagenes de flecha, que usan un estilo, para ordenar ASC o DESC el campo que yo indique; y debido a los estilos, la tabla se me hace redimensiona (se hace más estrecha) cada vez que quiero picar en alguna de esas flechas
:e). Es decir, de 100px baja a 60px, por poner un ejemplo, y tengo que actualizar la página varias veces para que vuelva a coger los 100px, y si paso el ratón por esas imágenes, se vuelve a 60px... un coñazo xD

He de incluir el estilos.css en cada carpeta?
:(No tiene lógica...
Es porque los estilos los declaro así--->   #estilo1 y no así ---> .estilo1? Lo único que varía es la llamada....

Muchas gracias por adelantado!


t3r4byt3
Machacateclados
Machacateclados
Haz clic para ver el perfil del usuario
Mensajes: 135
Desde: 25/Jul/2008
·
#2 · 25/Sep/2008, 00:30

No entiendo bien tu problema, si puedes explicarte mejor.

Sobre esto:

Cita:

Es porque los estilos los declaro así--->   #estilo1 y no así ---> .estilo1? Lo único que varía es la llamada....

No tiene nada que ver, si pones #estilo defines una ID y si pones .estilo defines una clase. Puede que el problema sea la llamada al css, al decir eso de si tienes que incluirlo en cada carpeta.

Ya me dirás que no sé exactamente que te pasa, si lo tienes online deja la dirección.

Salu2.


newboy_master
Usuario habitual
Usuario habitual
Haz clic para ver el perfil del usuario
Mensajes: 63
Desde: 08/Ago/2008
· ·
#3 · 25/Sep/2008, 10:08

Hola newboy.

Mi problema es que en los encabezados de cada columna de una tabla tengo dos imágenes; unas flechas que, según la que piques, se te ordena la tabla por ese campo, de manera ascendente o descendente. Lo único que he hecho ha sido subir un nivel el fichero estilos.css para poder hacer varias aplicaciones sin tener que copiar 4/5 veces el fichero de estilos. Y ahora, al posicionar el puntero sobre alguna de esas flechas que comenté antes, la tabla se redimensiona, haciéndose más estrecha, y me obliga a actualizar la página para volverla a ver normal.

La llamada está bien, la hago mediante un link stylesheet d'esos. El css lo tengo justo un nivel superior al resto de archivos, para así poder acceder desde cada aplicación sin poner una ruta muy larga,y sin copiar varias veces el mismo fichero. He pensado en poner los estilos generales fuera y, si necesito alguno personal, pues lo incluyo en la carpeta, aunque sea un verdadero coñazo... pero no veo otra solución por ahora.

Y sobre la dirección, te lo agradezco que me la pidas, pero es de una aplicación interna de la emprsa donde trabajo (intranet); lo siento :(

Muchas gracias por tu ayuda. :)


t3r4byt3
Machacateclados
Machacateclados
Haz clic para ver el perfil del usuario
Mensajes: 135
Desde: 25/Jul/2008
·
#4 · 25/Sep/2008, 18:43

Lo único que se me ocurre es que has aplicado la pseudoclase " :hover " en la tabla, en un ID  o en la imágen y al posarse sobre ella se redimensiona, fijate si has puesto en algún hover que la letra se haga más pequeña, o que pongas menos padding o margin.

Si quieres pasame el código por mp para verlo más claro y te digo a ver si te puedo ayudar.

Salu2.


newboy_master
Usuario habitual
Usuario habitual
Haz clic para ver el perfil del usuario
Mensajes: 63
Desde: 08/Ago/2008
· ·
#5 · 26/Sep/2008, 10:31

Buenas newboy.
Sí, tengo un a:hover para los enlaces, pero lo tengo en todas las aplicaciones que he hecho y solo me falla en esta xD y lo único que hago es "font-style:italic;" no hago más nada, ni font-size ni nada de nada.
Lo tengo "resuelto", le he cambiado el div id y ya no se me mueve ni hace cosas raras, yuju! pero me repatea 1 poko que por estar el css en un nivel superior ocurran estas cosas tan imprevistas.

Muchas gracias de todas maneras :)


t3r4byt3
Machacateclados
Machacateclados
Haz clic para ver el perfil del usuario
Mensajes: 135
Desde: 25/Jul/2008
·
#6 · 27/Sep/2008, 15:47

La verdad es que es muy raro que por estar en otro directorio salga mal, supongo que lo pondrás bien, te lo dejo por si te sirve de todas maneras:

Código:
<link rel="stylesheet" type="text/css" href="../estilos.css" media="screen" />

Salu2.


newboy_master
Usuario habitual
Usuario habitual
Haz clic para ver el perfil del usuario
Mensajes: 63
Desde: 08/Ago/2008
· ·
#7 · 01/Oct/2008, 09:52

Newboy, gracias por tu tiempo. El link al css lo tengo bien. Lo que he hecho ha sido meter esas imágenes en la carpeta de la aplicación y ya está... problema solucionado. Son imágenes pekeñas, asi q no me importa repetirlas...
Gracias nuevamente!


t3r4byt3
Machacateclados
Machacateclados
Haz clic para ver el perfil del usuario
Mensajes: 135
Desde: 25/Jul/2008
·
ATENCIÓN: Este tema no tiene actividad desde hace más de 6 MESES,
te recomendamos abrir un nuevo tema en lugar de responder al actual
Foro de soporte · Ayuda para webmasters · HTML avanzado
Opciones:
Versión imprimible del tema
Subscríbete a este tema
Date de baja de este tema
Ir al subforo:  
TU NO PUEDES Escribir nuevos temas en este foro
TU NO PUEDES Responder a los temas en este foro
TU NO PUEDES Editar tus propios mensajes en este foro
TU NO PUEDES Borrar tus propios mensajes en este foro
Ahora son las 13:32 UTC+01:00
Temas similares
 I FotoPTemaMensajesÚltima respuesta
No Hay mensajes nuevosHaz clic para ver el perfil del usuario
Por: Silphor · 21/Dic/2008, 12:33
121/Dic/2008, 12:40
Invitad@ Ir al último mensaje del tema
No Hay mensajes nuevosHaz clic para ver el perfil del usuario
Por: debaja · 27/Jun/2004, 17:32
1002/Jul/2004, 00:37
Defero_II Ir al último mensaje del tema
No Hay mensajes nuevosHaz clic para ver el perfil del usuario
Por: sk.valshk · 15/Sep/2006, 03:29
115/Sep/2006, 14:04
NoSetup.org Ir al último mensaje del tema
No Hay mensajes nuevosHaz clic para ver el perfil del usuario
Por: TheBlackWolf · 22/May/2009, 15:18
427/May/2009, 14:23
Invitad@ Ir al último mensaje del tema